MAXIMUM ALLOCATION FOR LOGICAL VOLUME VG_NAME is 1024 [AIX]

  Once I’m going to increase the filesystem /mount/point I’m facing the error 0516-787:

# df -g /mount/point
Filesystem      GB blocks Free   %Used Iused %Iused Mounted on
/dev/db2fs002lv 120.00    16.05   87%    14    1%   /mount/point

# chfs -a size=+110G /data/db2/fs002
0516-787 extendlv: Maximum allocation for logical volume db2fs002lv is 1024.

   This happen because the LVs have a maximum number of LPs, don’t worry you can add this number on the fly, without umount the filesystem. To check the real number of pp you can type “lslv db2fs002lv” :

#lslv db2fs002lv
LOGICAL VOLUME:     db2fs002lv             VOLUME GROUP:   data01
LV IDENTIFIER:      00c45b4500004c000000012acde604dc.15 PERMISSION:     read/write
VG STATE:           active/complete        LV STATE:       opened/syncd
TYPE:               jfs2                   WRITE VERIFY:   off
MAX LPs:            1024                   PP SIZE:        128 megabyte(s)
COPIES:             1                      SCHED POLICY:   parallel
LPs:                960                    PPs:            960
STALE PPs:          0                      BB POLICY:      relocatable
INTER-POLICY:       minimum                RELOCATABLE:    yes
INTRA-POLICY:       middle                 UPPER BOUND:    128
MOUNT POINT:        /mount/point           LABEL:          /mount/point
MIRROR WRITE CONSISTENCY: on/ACTIVE                              
EACH LP COPY ON A SEPARATE PV ?: yes                                    
Serialize IO ?:     NO                                     
INFINITE RETRY:     no       

  In red above will show how much PPs you have today, and the maximum. So we still have 64PP unused (((128MBx64)/1024) = 8GB)),In my case I need to double the space of the filesystem, so I’m going to change the MAX PP Number to the double of the current value :

#chlv -x 2048 db2fs004lv

#chfs -a size=+110G /mount/point
Filesystem size changed to 503316480

  You also can add the space via Smitty following the path below :
          #smitty chlv
             Change a Logical Volume
                Type the logical volume name
                    change : MAXIMUM NUMBER of LOGICAL PARTITIONS
                      [ENTER]

One comment

Leave a comment